+ Reply to Thread
Results 1 to 4 of 4

Thread: Is just because the C2 doesn't like the Cold *Help*

  1. #1
    Member N.L.Howell is on a distinguished road
    Join Date
    Aug 2017
    Location
    Pontyclun, South Wales
    Posts
    35

    Default Is just because the C2 doesn't like the Cold *Help*

    Morning,

    Past few weeks my 2004 C2 VTS really doesn't seem to want to run well especially from start.

    I've searched the forum and web and found a lot of the same sort of symptoms but never a definitive answer or the thread goes cold . Often seem to be met with C2's simply don't do well with the cold, battery, alternator, coil, plugs, ground ect. The usual minefield.

    Basically the C2 is a nightmare from initial morning or evening start (when cold) you've really got to let it idle for a good 10 minutes before considering moving it.

    From start it often cuts out unless a continues rev from turning the key as otherwise the revs drop to zero, battery light comes on then we have to try again.

    The same also happens when breaking or placing the car in neutral, the revs drop like you've just jumped out of a plane. The the car dies and battery life comes on, some times it corrects itself and some times you need to restart. I braked going up a hill last night and then nothing. Nothing like living on the edge with C2 life.
    • The battery was replaced last year.
    • The alternator appears to be charging the car but may have an underlying issue.
    • Plugs replaced two years ago but the car doesn't really do many miles (66,000 in total) not expensive to stick a new set in.
    • most sensors have been replaced when trying to fix my erratic stationary idle
    • It had a new throttle body two years ago.
    • No Fault codes ect
    • I've just put a redex short in this morning and treated it to 99 ron to see if it feel neglected.

    Based on the above where would people suggest i start first or is it a case of it is old and doesn't like cold weather.

    I've never managed to fix my previous issue have just learned to live with as it works and passes it's MOT ect just this is a bit of a headache especially if i need to factor 10/15 minutes in to my morning to Citroen emotional support.

    Thanks as always

    Nathan

  2. #2

    Default

    Seems like my C3 with vts engine issue. Seal of the injector was faulty and let air to suck in. As soon as it get hot will expand and stop leak.
    Check long term and short term fuel trim with a regual scantool and see if short term bounce up when cold.

    Had similar issue on other cars that have been lpg powered. Has your c2 been converted to lpg?

  3. #3
    Member N.L.Howell is on a distinguished road
    Join Date
    Aug 2017
    Location
    Pontyclun, South Wales
    Posts
    35

    Default

    C2 is petrol. The last few days it seems to have sort of corrected itself and the revs appear a little higher now.

    It’s such a random little car. I’ll take some readings and post the results.

    No idea what is deemed a good reading.

  4. #4
    C2 Addict Advanced Poster ozVTR is on a distinguished road ozVTR's Avatar
    Join Date
    Jan 2005
    Location
    Brisbane, Australia
    Posts
    1,042

    Default

    If the check engine isn't coming on, then the engine ECU "thinks" there is nothing wrong. There isn't to much the ECU doesn't keep an eye on and if the parameters aren't right it will whinge. Having said that there are a few things that can go wrong that it doesn't monitor.
    If you can get some data, take look at the engine temperature (in the diagnostic NOT the dash). Also see if the engine is in open or closed loop mode at start up.
    Engine temp when "cold" should show ambient. Engine should be in open loop until warmed up.

+ Reply to Thread

Similar Threads

  1. Antipollution fault - car doesn´t start
    By watergate in forum Advice, Queries & Technical Problems
    Replies: 4
    Last Post: 07-09-2017, 01:25 PM
  2. 2 keys one works; one doesn't...
    By matthew666 in forum General Chat
    Replies: 1
    Last Post: 18-07-2015, 07:35 PM
  3. Car won't start and key fob doesn't work?
    By CraftyMc in forum Advice, Queries & Technical Problems
    Replies: 3
    Last Post: 08-02-2014, 02:36 PM
  4. Unlock button on key doesn't work?
    By James c2 gt in forum Advice, Queries & Technical Problems
    Replies: 2
    Last Post: 08-07-2013, 10:37 AM
  5. Why the gf doesn't take pics...
    By Maleko in forum General Chat
    Replies: 15
    Last Post: 12-06-2008, 04:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts