+ Reply to Thread
Results 1 to 3 of 3

Thread: Problem with revs dropping between 1500-2000rpm

  1. #1

    Default Problem with revs dropping between 1500-2000rpm

    Hi all, I have a problem with my 1.4 56 plate furio. I need to give it a little throttle for it to start and also the revs drop between 1500-200rpm making the car kangaroo up the road. I have checked for vac leaks and replaced the throttle body but still the same. The rest of the Rev range is smooth so I think that will rule out the plugs and coil pack. Has anyone had this prob or knows of a fix? Any help will be much appreciated

  2. #2
    C2 Addict Advanced Poster ozVTR is on a distinguished road ozVTR's Avatar
    Join Date
    Jan 2005
    Location
    Brisbane, Australia
    Posts
    1,037

    Default

    Problems with the plugs or coil pack should bring up a check engine light but that's not a guarantee. Loss of power is typically because an engine is too rich (incomplete burn) or too lean (too much air, not enough fuel). I would have a look at the spark plugs anyway. This is not to say there is a problem with the plugs but they are a good indicator of what is going on inside the engine. Take note if they are clean and dry or if they are sooty. Also if any are different to the others. Check the gap (0.9mm) and clean them. If it's running rich the plugs will be sooty. Sorry, there is not much to go on so you have to start somewhere.

  3. #3

    Default

    Quote Originally Posted by ozVTR View Post
    Problems with the plugs or coil pack should bring up a check engine light but that's not a guarantee. Loss of power is typically because an engine is too rich (incomplete burn) or too lean (too much air, not enough fuel). I would have a look at the spark plugs anyway. This is not to say there is a problem with the plugs but they are a good indicator of what is going on inside the engine. Take note if they are clean and dry or if they are sooty. Also if any are different to the others. Check the gap (0.9mm) and clean them. If it's running rich the plugs will be sooty. Sorry, there is not much to go on so you have to start somewhere.
    Hi thank for your reply, I did think of plugs an coil but ruled this out as there are no fault codes relating to misfire or coil pack. Also I would have thought that the misfire would occur through out the Rev range but This fault happens at the same Rev range every time. Thank you for your reply it is much appreciated. I will check them just so I can eliminate it. Cheers

+ Reply to Thread

Similar Threads

  1. Just dropping in to say Hi!
    By BrandonR in forum Newbies
    Replies: 9
    Last Post: 24-02-2015, 10:45 AM
  2. New C2 owner dropping by to say Hi!
    By Keevilz in forum Newbies
    Replies: 3
    Last Post: 15-02-2015, 04:20 PM
  3. Revs jump when pressing clutch problem?
    By joe1983 in forum Advice, Queries & Technical Problems
    Replies: 11
    Last Post: 28-11-2011, 10:22 PM
  4. Replies: 15
    Last Post: 19-07-2009, 04:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts