+ Reply to Thread
Results 1 to 10 of 10

Thread: Abs pump and ecu ???????

  1. #1

    Default Abs pump and ecu ???????

    Hi all, need your help, abs light is on so changed pump but light is still on, bought the car as a non runner witch was standing for some 3 to 4 years, its a loeb. I think thay have changed the ecu but as the milage on the clock do not match the mot info, so my ? is are the abs pump and ecu matcted, if not is there a reset if you change the pump, .

  2. #2

    Default

    The loeb , vts and Code from 2006 onwards have abs with esp, really common fault on these cars is the esp pressure sensor ( which is buried in the abs valve lock failing , leaving you with an esp light on ( which is a test failure )also centre display warning keeps popping in
    Few firms out there repair said fault , you would need it on diagnostics to see why it’s doing what it’s doing really

  3. #3

    Default

    Thanks for the reply, unable to get a diag as the car is sorn and no mot, unable to find the proper pump with the same part number , the one i did find was faulty, so can i fit a pump from another vts ect, if so what onther parts would i need from the donor car, has any one tried this ? . Please help with any info as i need to keep loeb from the scrapyard grave

  4. #4

    Default abs

    ive split a abs pump and ecu which had different numbers than mine and the pump worked fine.

  5. #5

    Default

    Hi , witch part did you use , I assume you kept the black ecu ? and used the silver pump?

  6. #6

    Default abs

    i used the pump part,if i had have used the ecu i would of had to have it coded to the car as it had different numbers on it.

  7. #7

    Default

    Thanks for the info so far, I managed to get a abs pump of a norther loeb with the same numbers and after fitting and bleeding the brakes the same fault is there, is there a set way fitting these or am I just unlucky with the 2 I've had,

  8. #8

    Default

    Common fault with this system , send your old unit away and get it repaired properly

  9. #9

    Default

    Hi all again, so sent my unit away for repair but after fitting and bleeding the system I still have the same fault esp/asr fault. were do I go now ???????

  10. #10

    Default

    System needs to be bled properly using the Citroen diagnostic software to run the abs pump ,

+ Reply to Thread

Similar Threads

  1. Abs pump
    By badboy4lifel in forum Advice, Queries & Technical Problems
    Replies: 13
    Last Post: 08-03-2016, 06:25 PM
  2. ABS Pump Help?
    By Dylan Stevenson in forum Advice, Queries & Technical Problems
    Replies: 3
    Last Post: 26-06-2014, 06:44 PM
  3. oil pump
    By calvts in forum Advice, Queries & Technical Problems
    Replies: 3
    Last Post: 01-09-2011, 12:25 AM
  4. abs/esp pump
    By young fez in forum Advice, Queries & Technical Problems
    Replies: 9
    Last Post: 25-03-2011, 01:21 PM
  5. Air Con Pump
    By highlander in forum Advice, Queries & Technical Problems
    Replies: 2
    Last Post: 10-08-2009, 12:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts