+ Reply to Thread
Results 1 to 7 of 7

Thread: Alternator question.

  1. #1
    Lite Member SteveWHIP is on a distinguished road SteveWHIP's Avatar
    Join Date
    Apr 2016
    Location
    Norfolk
    C2 Model
    VTS
    Posts
    34

    Default Alternator question.

    Recently when driving the car lost all power and the dash lit up like a Christmas tree. It also clicked when attempting to start. I suspected this as an alternator issue. However looking at them there seems to be several variants of alternator. Will any work? I have a Citroen c2 vts 2006 thanks

    Sent from my Moto G (5) using Tapatalk

  2. #2
    Lite Member SteveWHIP is on a distinguished road SteveWHIP's Avatar
    Join Date
    Apr 2016
    Location
    Norfolk
    C2 Model
    VTS
    Posts
    34

    Default

    Denso

    Charge Current: 90, 80,90

    With Multi-Belt Pulley, 6 Ribs, 14 V Rated

    With 12V Main Current

    Belt Pulley Dia.:49.00mm

    Is the one I have been to looking to purchase but have no idea if it's compatible.



    Sent from my Moto G (5) using Tapatalk

  3. #3

    Default

    i just changed mine on the 1.1 and there are different one's,i just took mine to the breakers and matched it .
    20.bing bang bosh

  4. #4
    Lite Member SteveWHIP is on a distinguished road SteveWHIP's Avatar
    Join Date
    Apr 2016
    Location
    Norfolk
    C2 Model
    VTS
    Posts
    34

    Default

    I'm not really able to remove mine personally, so was hoping to be able to purchase one and have it fitted by somebody else. Just wanted to be sure I was getting the correct one though before hand

    Sent via the Time Space Continuim

  5. #5

    Default

    That doesn't sound like the symptoms of a broken alternator that you had Steve.
    It sounds more like an earth issue.
    Sometimes the earth strap on the gearbox wears away and causes problems like the ones you had.

    Andy

  6. #6
    Lite Member SteveWHIP is on a distinguished road SteveWHIP's Avatar
    Join Date
    Apr 2016
    Location
    Norfolk
    C2 Model
    VTS
    Posts
    34

    Default

    Cheers for that I'll look into it. I suspected the alternator as I know that plays havoc with the electrics

    Sent via the Time Space Continuim

  7. #7
    Member wurlycorner is on a distinguished road
    Join Date
    Nov 2017
    Location
    Chelmsford
    C2 Model
    By Loeb
    Posts
    65

    Default

    Yep sounds like earth problem or loose battery terminals.

+ Reply to Thread

Similar Threads

  1. Alternator
    By Arbie in forum Advice, Queries & Technical Problems
    Replies: 6
    Last Post: 21-02-2015, 07:28 PM
  2. C2 Mk1 VTS Alternator
    By mark_easywebuk in forum Advice, Queries & Technical Problems
    Replies: 9
    Last Post: 18-02-2011, 11:03 PM
  3. VTS/1.4 HDI Alternator fit a 1.1?
    By JayRee in forum Advice, Queries & Technical Problems
    Replies: 1
    Last Post: 22-01-2011, 03:30 AM
  4. Alternator Help
    By djeds in forum Advice, Queries & Technical Problems
    Replies: 2
    Last Post: 03-12-2010, 01:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts