+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 26 to 46 of 46

Thread: The Ultimate SensoDrive Owners Guide

  1. #26
    Newbie BeeryC is on a distinguished road
    Join Date
    Jan 2015
    Location
    Kent
    C2 Model
    Furio
    Posts
    10

    Default

    Hello everyone. I'm new to this and a girl so be gentle with me please.
    My car did the whole snowflake and flashing auto sign thing. A mechanic freind looked at it and said it needed a software update and reset on the clutch actuator. All duly done at the Citreon garage 2 days ago. This morning started her up left her a few minutes to warm up, reversed a few feet and when I went to put her into first the snowflake popped up. I switched her off then on again, engine wouldn't turn over.
    Rang the garage they said try to reset by disconnecting battery for 5 mins and then reconnect it and start, if it worked they said, just carry on driving it until it happens again!!!!!!! If not they'll have a look but it might be either the gearbox or actuator but they can't say which it might be????? Surely they can tell which it is before replacing one and finding out it's the other?
    Carried out the reset, the engine started and I was able to reverse 2 foot before changing into first and guess what...up popped the snowflake and no gears.

    Oh and when they did the software and reset they said there was clutch judder. Now I don't know what that is but surely I would've noticed it?
    Hope someone can help.
    Thanks
    Last edited by BeeryC; 29-01-2015 at 12:15 PM. Reason: added information

  2. #27
    C2 Addict Advanced Poster ozVTR is on a distinguished road ozVTR's Avatar
    Join Date
    Jan 2005
    Location
    Brisbane, Australia
    Posts
    1,032

    Default

    Hi BerryC
    Did they phisically reset the actuator or did they electrically rest the actuator? Electronically resetting the actuator is set out on the first page of this post and below and is also in the owners manual, anyone can do it. Physically resetting the actuator requires the actuator be moved backwards and forwards on the gearbox and
    can only be done by a technician who knows exactly what they are doing. If performing the reset as set out on the first page and below does not
    fix your problem take it back to Citroen and have the actuator physically adjusted if they didn't do it in the first place. Another
    thing is to get the battery load tested (a PROPER LOAD TEST not just
    testing with a multimeter). The condition of the battery is critical to the correct operation of the gearbox. It's winter time over there and the battery cops a flogging (er, the battery is under a lot of pressure LOL).

    You can not just pull the battery connector off and then stick it back on again. You have to go through a series of steps, they should have known that.

    Go back to the first page and the first post by Dryftkylt. Go to step 5. It is not necessary to remove the connection to the negative terminal just flip up the red connector on the positive terminal (the one closest to the front of the car) and remove the connector from the battery terminal. Remember it is critical that the gearbox click and clack for a good 30 seconds or else you have not reset it. Just keep trying until it does!
    You can not break anything. But remember to wait the 60 seconds before disconnecting the battery each time and wait 60 seconds after reconnecting the battery each time.

    Judder is where the clutch action is "rough". The clutch vibrates noticeably, typically on hard acceleration, just after changing gears. I wouldn't worry about this just yet. It is most likely the system "relearning" after the rest/update. The judder is typically from the way the actuator works and has nothing to do with the the actual clutch. Which is why it has magically appeared now!

    I'm sorry this post is long and convoluted but the poor C2 has had a bad rap because of the sensodrive "idiosyncrasies" and the fact that most (including genuine Citroen techs) don't understand how the system works! Many members here have had unnecessary and costly work done and wasted hundreds of pounds because
    the mechanics were just fishing! Er..sorry rant over :-).

    Good luck.

  3. #28
    C2 Addict Advanced Poster ozVTR is on a distinguished road ozVTR's Avatar
    Join Date
    Jan 2005
    Location
    Brisbane, Australia
    Posts
    1,032

    Default

    Trek has fixed up a Mk1 VTR and there are some interesting notes about the clutch actuator.

    http://www.c2club.co.uk/showthread.p...Citroen-c2-vtr

  4. #29

    Default

    Hi there , i`m new here.Can someone tell me what this mean "" Flip the rear ‘screen wiper down (on ‘reset’ the rear wiper sometimes runs for a few seconds) "" .Have a VTR with sensodrive.While driving in AUTO mode , ESP OFF button started flashing , two lamps on dash appeared (something like drifting car) and car stuck on 2nd gear.When i turn the engine off and on again , it works properly.What can the problem be , and is this the "snowflake icon" on the dash or something else ? Havent seen anything like snowflake *

  5. #30

    Default The Ultimate SensoDrive Owners Guide

    Quote Originally Posted by berof View Post
    Hi there , i`m new here.Can someone tell me what this mean "" Flip the rear ‘screen wiper down (on ‘reset’ the rear wiper sometimes runs for a few seconds) "" .Have a VTR with sensodrive.While driving in AUTO mode , ESP OFF button started flashing , two lamps on dash appeared (something like drifting car) and car stuck on 2nd gear.When i turn the engine off and on again , it works properly.What can the problem be , and is this the "snowflake icon" on the dash or something else ? Havent seen anything like snowflake *
    Carry out a BSI reset ( Google it
    Read and follow the procedure exactly , if no success it needs to go on diagnostics
    Last edited by Trek; 30-03-2015 at 12:39 PM.

  6. #31
    C2 Addict Advanced Poster ozVTR is on a distinguished road ozVTR's Avatar
    Join Date
    Jan 2005
    Location
    Brisbane, Australia
    Posts
    1,032

    Default

    The rear windscreen wiper may start running when you re-connect the battery. Just flip it off the glass to reduce the chance of it scratching the glass.

  7. #32

    Default

    I have copied the following text from a posting by DryftKylt on this forum so I don't have to explain what my question relates to -

    This similar yet far more serious problem is one that has only recently come to my attention after I spent many years screaming and swearing at my local dealership to fix the problem, basically resulting in total loss of drive when shifting from second to first and resulting in nothing but a boot full of revs, and if kept on revs for too long an accompanying snowflake of death. Sometimes initializing the transmission when the vehicle is cold will allow the vehicle to be started again if the problem is in early stages but if the problem has advanced you will find yourself stranded and only the dealership can help you. The cause of this I recently found was the selector fork assembly, the pin securing the fork to the shaft wears loose allowing slop in the mechanism causing the fork to not quite knock the transmission into first, usually selecting neutral then shifting back into first was enough to get me going again but when it finally decided it had had enough I made the call to have the dealer look inside the box. This is a transmission out job and it was rectified by drilling out the assembly to take a larger pin, since then this problem has disappeared entirely.

    My question is; Would it be possible for my mechanic to replace this pin during a clutch change on my 2005 VTR ? Would this fork and pin be something obvious to the mechanic while the clutch is removed or does he have to completely remove the gearbox to locate and replace this pin with a tighter fitting one that takes up any slack or movement ?

    Any help or advise on this subject would be greatly appreciated.
    Thanx, Pol.

  8. #33

    Default

    No , it's internal in the gearbox

  9. #34

    Default

    Is it a gearbox out job to get to this pin..........

  10. #35

    Default

    Read the first post , it does tell you

  11. #36
    Newbie JMG is on a distinguished road
    Join Date
    Dec 2015
    Location
    Madrid
    C2 Model
    VTR 1.4i 2004
    Posts
    2

    Default

    Hi everybody, I have a C2 1.4 VTR 2004 with problems in the gearbox.
    The display shows no gear " - " and service symbol flashing.
    For moving the car, I removed the shift-actuator to select "N" manually because it was very blocked and aligned the actuator...
    It was the same displayed
    I bought a diag tool after having notice about the citroen BILL.
    It shows intermediate position of the actuator and 4th engaged when it is "N"

    Which is this sensor??
    Is there any way to calibrate manually the shift-actuator??

    Thanks
    ...Very good the maintenance info...
    I will try tomorrow to make the reset procedure
    Last edited by JMG; 07-12-2015 at 01:30 AM.

  12. #37

    Default

    Gear position sensor is in top of gearbox screwed in , any configuration needs to be done with lexia including software update and initial calibration ( which needs to be done every time anything is removed/ replaced .... This is a learning process for the actuator which is the stored in ecu , same with clutch bite )

  13. #38
    Newbie JMG is on a distinguished road
    Join Date
    Dec 2015
    Location
    Madrid
    C2 Model
    VTR 1.4i 2004
    Posts
    2

    Default

    Hi Trek
    I did everything without battery, only when I had everything aligned and conected, I run the autokom
    It did not detect the shift lever´s pulses, and when I remove the sensor plug (black one), also it did not change the info displayed (4th engaged).

    Is this black sensor damaged or is there something wrong in the ECU?

    I´ve seen lexía used units in the net, how can I diference the originals and the copys?

    Are the copys enough good for these reprogramming operations?

    Thanks

  14. #39

    Default

    Need diag or lexia to do anything , nothing else is any good , and decent lexia/diag copy works as that's what I use

  15. #40

    Default

    Thanks for the advice, had both gearbox fault and stop-start fault displayed. Car would drive but gear changes rough. Followed procedure to reset the ECUs now both faults cleared and drives more smoothly than it has in a while.

  16. #41
    Member street8 is on a distinguished road street8's Avatar
    Join Date
    Apr 2012
    Location
    Cradley Heath
    C2 Model
    HDi Sensodrive
    Posts
    78

    Default

    Hi all. I have a problem with my C2 1.4HDi Furio Sensodrive. Basically it has been driving fine with no warning lights, however I went out a few nights ago to the local petrol station, filled the tank with diesel and returned home and parked the car, nothing out of the ordinary. I came to start it the following morning to go to work but it won't start!

    The gear selector is showing '_' and when I turn the ignition to the accessories position it flashes 'Auto' and '*' (snowflake of death) accompanied by a few beeps.

    I have tried the reset procedure, however I'm not sure what's meant by put the rear wiper in the down position? Does this mean off the glass? Alas all the fiddling about trying to reset the damn thing has sent it into eco mode so I have removed the battery to charge it. However that has thrown up another conundrun as I can lock the drivers door with the key but not the passenger door

    Is their a way to lock the passenger door without the central locking? And is there any way of getting the damn thing to start as I don't have home start so getting it to a garage could be difficult.

  17. #42

    Default

    Does the rear wiper thing mean the stork? AND Bradley heath! Woop, another yam yam.

  18. #43
    Member street8 is on a distinguished road street8's Avatar
    Join Date
    Apr 2012
    Location
    Cradley Heath
    C2 Model
    HDi Sensodrive
    Posts
    78

    Default

    Quote Originally Posted by Tommylee View Post
    Does the rear wiper thing mean the stork? AND Bradley heath! Woop, another yam yam.
    Cradley Heath is miles from yam yam territory

    Good news, charged the battery, reconnected it. Put my foot on the brake for 30 seconds or so, clicking and clacking and hey presto a '1' appeared. Started fine so took it for a 30 minute drive (no problems).

    Thinking it may need a new battery as it was caked in a white chalky deposit (lead sulphate?)

  19. #44

    Default

    Anywhere past Rowley s yam yam land.

  20. #45
    Member street8 is on a distinguished road street8's Avatar
    Join Date
    Apr 2012
    Location
    Cradley Heath
    C2 Model
    HDi Sensodrive
    Posts
    78

    Default

    I've always classed yam yams as people from Wolvo. The girlfriend is from Dudley and she thought it referred to Brummies!

    Re: The car, had to buy a new battery. Nice bloke at the shop even tested the alternator for free and its all good.

    Many thanks to the authour/contributors to this thread, saved me an expensive trip to the garage.

  21. #46

    Default

    just bught a c2 vtr with a few prblems so glad i joined this site thanks all the advice for various issues has been priceless

+ Reply to Thread

Similar Threads

  1. ultimate street car ?
    By farriertom in forum Past Meets & Shows
    Replies: 20
    Last Post: 20-06-2013, 11:29 PM
  2. Ultimate Street Car
    By DC_VTS in forum General Chat
    Replies: 3
    Last Post: 04-07-2012, 05:04 PM
  3. Ultimate Street Car @ Santa Pod
    By SeniorGT in forum Past Meets & Shows
    Replies: 0
    Last Post: 04-08-2011, 02:47 AM
  4. Sensodrive Owners!
    By JonnyW in forum Advice, Queries & Technical Problems
    Replies: 7
    Last Post: 22-02-2010, 12:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts